This forum requires Javascript to be enabled for posting content
 
Current User: Guest Login Register Members
Please consider registering


Register? | Lost Your Password?

Search Forums:


 






Minimum search word length is 1 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

Problems with RS232 converter

Add a New Topic Reply to Post
UserPost

17:35
2012/03/12


Shaun

I have been using RDSSpy with my Sony ST-SB920 using the sound card. I wanted to free the soundcard for other applications and built the RS232 converter. This is not working. Current draw is about 4.5mA. It opens the serial port and on the status screen, I get about 333 received bits per second, no ones and 333 zeros. I think my missing ones is the problem. I have traced the inputs with a scope through to the 555 chip and there is clearly an output of sorts. How critical is the use of a foil capacitor for the 10n capacitor, and which of the two 10n's is it? Any advice would be appreciated. Shaun.

18:06
2012/03/12


DXer

Close the RDS Spy and connect to the serial port using Windows Hyperterminal 19200 Bd, 8 data bits, no parity, 1 stop bit, no flow control. Copy and paste here the text you receive.
Are you sure you are opening the right COM port? The value of 333 is interesting as it probably not a random value. The RS232 converter, if built well, works absolutely without problems. Foil capacitor is the one connected to pin 6, it's due to the fact that foil capacitors are better precision but this does not mean that ceramic will not work.

19:59
2012/03/12


Shaun

Thanks DXer!
I have tried reading the output with Hyperterminal, but it receives nothing. The figures in the bits and zeros are both the same, and update themselves every 2-3 seconds. They seem quite stable, as if it is reading something, rather than just random noise. They vary from station to station, but are in the range 300-360. I only have one Com port on this PC, Com1, so I don't think that is the problem. The 10n capacitors I ordered were described as multilayer, although I have changed both for polyester types. However, this made no difference. I have rechecked my layout carefully, checked the supply rail ( 5.4V from the tuner) and am really puzzled by this one! Shaun.

21:03
2012/03/12


DXer

If you cannot see data in Hyperterminal, the problem is surely not in the RDS Spy. Your PC does not receive the data.
What about connecting your oscilloscope to the converter output? You must see TLL (square) signal with frequency of 1187.5 kHz and variable duty cycle.
Maybe your COM port is one of a few that does not accept TTL levels (requires negative voltage instead of 0 V). You may try to solve this connecting the TxD-RxD wire not directly but through a 10 uF capacitor (or similar), + lead to the converter.
If still no success, buy a serial-to-USB adapter, new COM port will appear in your system, and this usually works.

21:11
2012/03/12


Shaun

Thanks again DXer!
Some progress. I discovered an error in laying out the veroboard. For some inexplicable reason, I connected the 100n supply decoupler to pins 6-7! I have corrected this now. I now get much higher figures for bits and zeros, 1200ish, but no ones. Hyperterminal now reads this;
øüøüüøøøüøøøøøøüüüøüøøüøøøøøøøüøüøøøøüüüøøüøüøøøøüüøøüüøøøüøøüøøøøøøøøøøøøøøøøøø
øüüøüüøüøøüüøøüøüøøøøüüøøüøüüøøøüøøøüüüøøüøüøøüøøøøüøøøüüüøüøüøüøøøøüüøüüüüøøüøü
øøøüüüüøüüøøøøüüøøüøøüüüøüøøøüøøøüüüøøüøüøøøøüüøøüøüüøøøüøøøøøøøøüøüøøüøüøüøøøü
Thanks for your prompt advice. Shaun.

21:48
2012/03/12


DXer

I think you will do the best if you check the converter circuit again. It seems the basic function is now present but there's surely still some problem around the 555.
If you can, capture the hyperterminal output to a file and upload the file here. This may tell more. It seems simple Copy & Paste corrupts coding.

21:56
2012/03/12


Shaun

Thanks again DXer!
I have saved a file, but do not know how to upload it here. Its getting late now and I am beginning to get tired, so I think a pair of fresh eyes in the morning might spot another error more easily.
With thanks & kind regards, Shaun.

12:02
2012/03/13


Shaun

Well, I've finally got it going! I replaced the polyester capacitor that I tried between pin 6 and ground with the original multilayer one. I also wondered if the supply voltage (5.3-5.4V) was slightly too high and placed a diode in the line to reduce it to 4.7V. I'm not sure which made the difference, but it is running superbly now! Thanks DXer, for your help and encouragement. Kind regards, Shaun.

16:37
2012/03/13


Shaun

Well, I spoke too soon! Twice now, I've had it running well for ten minutes or so, only to screw the cover back on and for it to stop. Now I've got lots of ones, but no zeros. I suppose there must be an intermittent somewhere, but it is not easy finding it!

17:15
2012/03/13


Shaun

I've just noticed that the circuit diagram specifies the CMOS version of the 555, but I have used the bipolar 555N. According to the notes in the Maplin catalogue, the 555N requires a bigger supply decoupling capacitor. I've just put a 47uF in, but it hasn't made any difference. Is use of the CMOS version critical?

19:17
2012/03/13


DXer

Why do you solve CMOS or bipolar? It already worked for you so this is surely not the problem. Somebody has already confirmed in this forum that CMOS or bipolar it does not make any difference in this circuit. Check the circuit for broken wire or lead.

20:16
2012/03/13


Shaun

Thanks again DXer!
This is really odd. It seems that it works when it has been left for a couple of hours and is cold. After running for a few minutes, it stops. It has done this three times today now. I have pulled and tugged every lead and tapped the board with a screwdriver handle, but cannot trace it. Might be a microscopic fracture in a component somewhere. I think the quickest solution is to run up a new board with new components. I'll let you know how I get on! Shaun.

16:37
2012/03/18


Shaun

I've built a second board with a CMOS 555, and this has been running well for over half an hour now. Fingers crossed, I think we've cracked it at last!

16:44
2012/03/18


Shaun

Would you believe it, no sooner than I post the above and it stops working. As with the previous board, it gets to 29 blocks and stops. Must be something significant in that.

Reply to Post

Reply to Topic:
Problems with RS232 converter

Guest Name (Required):

HTML Editor
Smileys
Confused Cool Cry Embarassed Frown Kiss Laugh Smile Surprised Wink Yell
Post New Reply

Guest URL (required)

Math Required!
What is the sum of:    


About the RDS Spy – Windows RDS Decoder Forum

Forum Timezone: UTC 1

Most Users Ever Online: 36

Currently Online:
4 Guests

Currently Browsing this Topic:
1 Guest

Forum Stats:

Groups: 2
Forums: 10
Topics: 60
Posts: 244

Membership:

There are 419 Members
There have been 30 Guests

There is 1 Admin

Top Posters:

Skywaves – 18
veso266 – 15
DaveB – 12
G4FBZ – 10
M3EMB – 8
benko5009 – 5

Recent New Members: omlishtr, lokirry, ofkimotar, lipslogi, dimajanlix, dolfrjapi

Administrators: admin (77 Posts)